remove_action('wp_head', 'wp_generator');
{"id":60,"date":"2014-01-04T00:24:26","date_gmt":"2014-01-03T22:24:26","guid":{"rendered":"http:\/\/mywebhoster.de\/wp\/?page_id=60"},"modified":"2014-01-04T00:24:26","modified_gmt":"2014-01-03T22:24:26","slug":"cgi","status":"publish","type":"page","link":"https:\/\/mywebhoster.de\/?page_id=60","title":{"rendered":"CGI"},"content":{"rendered":"<p><strong>1. CGI-Skripte auf meinem\u00a0Webspace werden nicht ausgef\u00fchrt. Ich erhalte eine Fehlermeldung (z.B. 500 Internal Server Error) oder bekomme die Datei zum Download angeboten, wenn ich sie aufrufe.\u00a0\u00a0<\/strong><\/p>\n<p><span style=\"text-decoration: underline;\"><strong>M\u00f6gliche Ursachen und L\u00f6sungen:<br \/>\n<\/strong><\/span><\/p>\n<p>1.: Richtiges CGI-Verzeichnis<br \/>\nStandardm\u00e4\u00dfig werden CGI-Skripte nur verarbeitet, wenn sie im Verzeichnis \/cgi-bin\/ liegen, welches von der Confixx-Software unter dem Ordner \/html\/ automatisch erstellt wird.<br \/>\nAu\u00dferhalb dieses Verzeichnisses werden CGI-Skripte nur ausgef\u00fchrt, wenn Sie dies in Confixx (als Endkunde!) speziell freigeben. Diese Freigabe liegt etwas versteckt in der \u00dcbersicht unter &#8222;Allgemein&#8220; beim Endkunden, der Punkt lautet<br \/>\nCGI\/Perl au\u00dferhalb cgi-bin | Deaktiviert <span style=\"text-decoration: underline;\">\u00e4ndern<\/span><br \/>\nDeaktiviert ist die Voreinstellung.<\/p>\n<p>2.: CGI au\u00dferhalb \/cgi-bin\/ und es klappt trotzdem nicht!<br \/>\n\u00dcberpr\u00fcfen Sie, ob in der Datei \/etc\/apache2\/mod_mime-defaults.conf der folgende Eintrag existiert:<br \/>\nAddHandler cgi-script cgi pl pm<br \/>\nExistiert diese Eintrag nicht, so f\u00fcgen Sie ihn am Ende der Datei ein. Benutzen Sie zur Bearbeitung von Linux-Textdateien aber niemals einen Windows-Editor, sondern einen Linux-Editor wie z.B. joe oder mcedit! (mcedit ist der integrierte Editor aus dem Midnight Commander (Norton Commander Clone), welcher mit mc aufgerufen wird)<br \/>\nNach einer \u00c4nderung an der Datei m\u00fcssen Sie den Apache Webserver neu starten:<br \/>\n\/etc\/init.d\/apache2 stop &amp;&amp; \/etc\/init.d\/apache2 start<\/p>\n<p>3.: Richtige Rechte gesetzt?<br \/>\nCGI-Skripte d\u00fcrfen Sie in Sachen Benutzer und Gruppe nach dem FTP-Upload NICHT ver\u00e4ndert werden, d.h. es bleibt bei Besitzer = webXX und Gruppe entweder auch = webXX oder Gruppe = ftponly (das h\u00e4ngt vom System ab).<br \/>\nWichtig ist jedoch, da\u00df Sie die Ausf\u00fchrungsrechte aktivieren, und zwar m\u00fcssen CGI-Skript (.cgi und .pl) auf chmod 0755 gestellt werden. Stellen Sie die Rechte aber NICHT (wie von manchen Skripten in der Dokumentation gefordert) auf 777 &#8211; so bekommen Sie ganz gewi\u00df Probleme mit 500 Internal Server Error.<\/p>\n<p>4.: Ich habe immer noch Probleme!<br \/>\nWenn Sie weiterhin Probleme mit CGI-Skripten haben, obwohl Sie ALLE Hinweise in diesem Artikel beachtet und \u00fcberpr\u00fcft haben, so er\u00f6ffnen Sie bitte ein Support-Ticket. Bitte beachten Sie jedoch, da\u00df wir nicht bei spezifischen Problemen helfen k\u00f6nnen, d.h. wenn ein Skript funktioniert und ein anderes nicht, so liegt es vermutlich am Skript und unsere Hilfsm\u00f6glichkeiten sind sehr begrenzt. (Skript-Debugging ist NICHT in unserem Standardsupport enthalten!)<\/p>\n","protected":false},"excerpt":{"rendered":"<p>1. CGI-Skripte auf meinem\u00a0Webspace werden nicht ausgef\u00fchrt. Ich erhalte eine Fehlermeldung (z.B. 500 Internal Server Error) oder bekomme die Datei zum Download angeboten, wenn ich sie aufrufe.\u00a0\u00a0 M\u00f6gliche Ursachen und L\u00f6sungen: 1.: Richtiges CGI-Verzeichnis Standardm\u00e4\u00dfig werden CGI-Skripte nur verarbeitet, wenn [&hellip;]<\/p>\n","protected":false},"author":1,"featured_media":0,"parent":0,"menu_order":0,"comment_status":"closed","ping_status":"closed","template":"","meta":{"footnotes":""},"class_list":["post-60","page","type-page","status-publish","hentry"],"_links":{"self":[{"href":"https:\/\/mywebhoster.de\/index.php?rest_route=\/wp\/v2\/pages\/60","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/mywebhoster.de\/index.php?rest_route=\/wp\/v2\/pages"}],"about":[{"href":"https:\/\/mywebhoster.de\/index.php?rest_route=\/wp\/v2\/types\/page"}],"author":[{"embeddable":true,"href":"https:\/\/mywebhoster.de\/index.php?rest_route=\/wp\/v2\/users\/1"}],"replies":[{"embeddable":true,"href":"https:\/\/mywebhoster.de\/index.php?rest_route=%2Fwp%2Fv2%2Fcomments&post=60"}],"version-history":[{"count":1,"href":"https:\/\/mywebhoster.de\/index.php?rest_route=\/wp\/v2\/pages\/60\/revisions"}],"predecessor-version":[{"id":61,"href":"https:\/\/mywebhoster.de\/index.php?rest_route=\/wp\/v2\/pages\/60\/revisions\/61"}],"wp:attachment":[{"href":"https:\/\/mywebhoster.de\/index.php?rest_route=%2Fwp%2Fv2%2Fmedia&parent=60"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}